Перейти к содержанию
BlackBerrys.ru
morgoth

AppWorld вызывает проблемы с Desktop Manager

Рекомендуемые сообщения

Всем привет,

После апгрейда OS на Bold 9000 с 4.6.какой-то на вот эту 9000M_PBr5.0.0_rel1728_PL5.2.0.89_A5.0.0.1067_AT_T.exe (апгрейд делал на виндовсе через loader, без очистки с бэкапом и восстановлением из него) вылезла странная проблема под маком.

При нажатии кнопки Applications в DM как и раньше появляется список установленных приложений, но после нажатия кнопки Start (не важно - добавляем программу, удаляем или вообще не трогаем ничего) через некоторое время вылезает ошибка:

BlackBerry® Desktop Software failed to validate your BlackBerry® device update.

Aborting install due to validation failure. Some packages contained unsatisfied dependencies.

Чтобы определить какое приложение выдает ошибку посмотрел лог и нашел вот что:

(3501) 2011-12-13 08:54:18.972 INFO JL_CONFIG Commands Couldn't find required dependency named: net_rim_bb_qm_platform for package: <BDJLPackage: 0x7b16010>(BlackBerry App World:Research In Motion Limited, 3.0.1.29, handle=3608 S=0 H=0 R=0 A=1 O=1) in configuration

(3501) 2011-12-13 08:54:20.667 ERROR*** INSTAPPS Commands Aborting install due to unsatisfied dependencies for packages: ( <BDJLPackage: 0x7b16010>(BlackBerry App World:Research In Motion Limited, 3.0.1.29, handle=3608 S=0 H=0 R=0 A=1 O=1) )

(3501) 2011-12-13 08:54:20.668 ERROR*** default Commands Exception BDValidationException -- BDValidationException (Aborting install due to validation failure. Some packages contained unsatisfied dependencies.) created

(3501) 2011-12-13 08:54:20.668 ERROR*** UPDATE Commands Aborting command because it failed validation: Aborting install due to validation failure. Some packages contained unsatisfied dependencies. type: 0 errno: 0 [NessusCommand BDNessusUpdateDeviceCommand [Device name:BlackBerry Bold 9000 pin: model:BlackBerry Bold 9000 hardwareID:0x84000E07 GUID: - apps:5.0.0.1067 platform:5.2.0.89]]

Получается что ошибку вызывает AppWorld (который сам захотел проапгрейдится после обновления прошивки и обновился успешно до версии 3.0.1.29).

Если удалить AppWorld то ошибка пропадает, все работает как и со старой прошивкой.

Если установить то ошибка снова появлятся.

При этом если AppWorld установлен, то из браузера через сайт appworld.blackberry.com приложения ставятся, так что значит AppWorld вполне себе рабочий. И если его запустить то тоже все работает.

Если подключить телефон к виндовсовскому десктоп менеджеру, то все работает, ошибок нет. Он правда в отличие от маковского еще предлагает встроенные приложения убрать установить.

Кстати под виндовс, если подключить телефон и ткнуть в приложения, ничего не выбирать и нажать применить, то начинают обновляться/ставиться какие-то .cod (несколько разных, не успел записать какие), но в итоге ошибок не выводится и работает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Гость
Ответить в этой теме...

×   Вставлено с форматированием.   Вставить как обычный текст

  Разрешено использовать не более 75 смайлов.

×   Ваша ссылка была автоматически встроена.   Отображать как обычную ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставлять изображения напрямую. Загружайте или вставляйте изображения по ссылке.


×
×
  • Создать...